Welcome

M9185A PXI D/A Converter

LabVIEW G Programming Information

This help file contains the LabVIEW G programming information for the M9185A PXI D/A Converter.

  • Introduction
  • Programming Examples
  • Method (VI) Reference
  • Related Documentation

© Agilent Technologies, Inc. 2011

Version 1.0


Introduction

Introduction to the AgM9185 LabVIEW Driver

The AgM9185 LabVIEW Driver allows you programmatic control for the M9185A PXI D/A Converter.
The Agilent M9185A is a digital/analog converter (D/A converter) which has eight or 16 independent, isolated channels capable of supplying high voltage levels in parallel as stimulus signals to the device-under-test (DUT).

See Also:
  • Agilent M9185A product Web site
  • Block diagram
  • VI descriptions
  • Examples
  • Related documentation


M9185A Block Diagram


Scenarios and Sample Programs

Programming Examples for the AgM9185 LabVIEW Driver

The following example programs are provided to demonstrate most features in the M9185A PXI D/A Converter. Each example VI has a front panel you can use to exercise the underlying VI functions.

  • Agilent M9185-Event

  • Agilent M9185-Group

  • Agilent M9185-Trigger


Agilent M9185-Event.vi

Agilent M9185-Event

This example initializes the instrument, reads a few Identity interface

properties, and checks the instrument error queue.

Also configures an event.


Agilent M9185-Group.vi

Agilent M9185-Group

This example initializes the instrument, reads a few Identity interface

properties, and checks the instrument error queue.

Also configures a channel group


Agilent M9185-Trigger.vi

Agilent M9185-Trigger

This example initializes the instrument, reads a few Identity interface

properties, and checks the instrument error queue.

Also includes additional instrument specific functionality.


Agilent M9185.lvlib:GetAttributeViBoolean.vi

GetAttributeViBoolean

Gets a Boolean attribute from the instrument driver.

The following Attributes are supported:

SIMULATE

OUTPUT_ENABLED

SYSTEM_TRACE_ENABLED

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported:

SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

OUTPUT_ENABLED : This property is used to control the output switch state (True for "On" and False for "Off") of the specified channel.

SYSTEM_TRACE_ENABLED : If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver.The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Agilent IO Libraries 16.0 or newer.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.

ibool

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Agilent M9185.lvlib:GetAttributeViInt32.vi

GetAttributeViInt32

Gets an Int32 attribute from the instrument driver.

The following Attributes are supported:

OUTPUT_COUNT

OUTPUT_FUNCTION

SYSTEM_SLOT_NUMBER

TRIGGER_SLOPE

EVENT_SLOPE

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported:

OUTPUT_COUNT : Returns the number of outputs.

OUTPUT_FUNCTION : Read the measurement function (Voltage or Current) of the specified channel.

SYSTEM_SLOT_NUMBER : Returns the the slot number of the card.

TRIGGER_SLOPE : Gets the edge of the hardware trigger input pulse. Edge can be either Positive or Negative.

EVENT_SLOPE : Gets the edge of the hardware trigger output pulse. Edge can either be Positive or Negative.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.

ii32

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Agilent M9185.lvlib:GetAttributeViReal64.vi

GetAttributeViReal64

Gets a Real64 attribute from the instrument driver.

The following Attributes are supported:

OUTPUT_LEVEL

EVENT_PULSE_WIDTH

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported:

OUTPUT_LEVEL : Read the output level of the selected function (Voltage or Current).

EVENT_PULSE_WIDTH : Gets the Pulse width in microseconds. Range is 0.02us to 300us, default value is 1us.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.

idbl

AttributeValue

Returns the current value of the property. The user must specify the address of a variable that has the same data type as the property.


Agilent M9185.lvlib:GetAttributeViString.vi

GetAttributeViString

Gets a String attribute from the instrument driver.

The following Attributes are supported:

SPECIFIC_DRIVER_DESCRIPTION

SPECIFIC_DRIVER_VENDOR

SPECIFIC_DRIVER_REVISION

LOGICAL_NAME

IO_RESOURCE_DESCRIPTOR

DRIVER_SETUP

SUPPORTED_INSTRUMENT_MODELS

INSTRUMENT_FIRMWARE_REVISION

INSTRUMENT_MANUFACTURER

INSTRUMENT_MODEL

SYSTEM_SERIAL_NUMBER

SYSTEM_BOARD_REVISION

SYSTEM_FPGA_REVISION

SYSTEM_DRIVER_REVISION

SYSTEM_CALIBRATION_DATE

TRIGGER_SOURCE

EVENT_DESTINATION

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed.Following attributes are supported:

SPECIFIC_DRIVER_DESCRIPTION : Returns a brief description of the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SPECIFIC_DRIVER_VENDOR : Returns the name of the vendor that supplies the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

SPECIFIC_DRIVER_REVISION : Returns version information about the IVI specific driver. The string that this attribute returns contains a maximum of 256 bytes including the NUL byte.

LOGICAL_NAME : Identifies a driver session in the Configuration Store. If Logical Name is not empty, the driver was initialized from information in the driver session. If it is empty, the driver was initialized without using the Configuration Store.

IO_RESOURCE_DESCRIPTOR : Specifies the connection to a physical device. It is either specified in the Configuration Store or passed in the ResourceName parameter of the Initialize function. It is empty if the driver is not initialized.

DRIVER_SETUP : The driver setup string. It is either specified in the Configuration Store or passed in the OptionString parameter of the Initialize function. Driver setup is empty if the driver is not initialized.

SUPPORTED_INSTRUMENT_MODELS : A comma-separated list of instrument models that the IVI specific driver can control. The string does not include an abbreviation for the manufacturer if it is the same for all models.

INSTRUMENT_FIRMWARE_REVISION : The firmware revision reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the firmware revision, a string is returned that explains the condition.

INSTRUMENT_MANUFACTURER : The name of the manufacturer reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the name of the manufacturer, a string is returned that explains the condition. Manufacturer is limited to 256 bytes.

INSTRUMENT_MODEL : The model number or name reported by the physical instrument. If Simulation is enabled or the instrument is not capable of reporting the model number or name, a string is returned that explains the condition. Model is limited to 256 bytes.

SERIAL_NUMBER : Returns a comma separated list of the serial numbers of the modules that compose the M9392A VSA. Use GetModuleIdentity() to identify which serial number is associated with each module.

SYSTEM_BOARD_REVISION : Returns the PCB version.

SYSTEM_FPGA_REVISION : Returns the FPGA firmware version.

SYSTEM_DRIVER_REVISION : Returns the fundamental driver revision.

SYSTEM_CALIBRATION_DATE : Returns the Calibration Date from EEPROM.

TRIGGER_SOURCE : Gets the string containing hardware trigger input pulse ("Immediate" or "EXT" or "PXI<n>"). While setting, "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5". If the specified source value is other than "Immediate", the driver automatically sets the Event Destination to "OFF" before setting the source value.

EVENT_DESTINATION : This is a string containing hardware trigger output pulse ("OFF" or "EXT" or "PXI<n>"). "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5". If the specified destination value is other than "OFF", the driver automatically sets the Trigger Source to "Immediate" before setting the destination value.

ci32

AttributeValueBufferSize

The number of bytes in the string that the user specifies for the AttributeValue parameter.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.

istr

AttributeValue

The buffer in which the VI returns the current value of the property. Can be VI_NULL (0) if AttributeValueBufferSize is 0.


Agilent M9185.lvlib:SetAttributeViBoolean.vi

SetAttributeViBoolean

Sets a Boolean attribute from the instrument driver.

The following Attributes are supported:

SIMULATE

OUTPUT_ENABLED

SYSTEM_TRACE_ENABLED

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported:

SIMULATE : If True, the driver does not perform I/O to the instrument, and returns simulated values for output parameters.

OUTPUT_ENABLED : This property is used to control the output switch state (True for "On" and False for "Off") of the specified channel.

SYSTEM_TRACE_ENABLED : If true, output trace log of all driver calls to an XML file using a unique file name based on date and time in the same directory as the application executable accessing the driver OR as specified using tracing options when initializing the driver.The log file may be viewed in your web browser. If enabled, driver trace and additional IO events may also be viewed in the IO Monitor utility of Agilent IO Libraries 16.0 or newer.

cbool

AttributeValue (Off)

The value to which to set the property.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:SetAttributeViInt32.vi

SetAttributeViInt32

Sets an Int32 attribute from the instrument driver.

The following Attributes are supported:

TRIGGER_SLOPE

EVENT_SLOPE

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

AttributeID

Selects which attribute will be accessed. Following attributes are supported:

TRIGGER_SLOPE : Sets the edge of the hardware trigger input pulse. Edge can be either Positive or Negative.

EVENT_SLOPE : Sets the edge of the hardware trigger output pulse. Edge can either be Positive or Negative.

ci32

AttributeValue

The value to which to set the property.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:SetAttributeViString.vi

SetAttributeViString

Sets a String attribute from the instrument driver.

The following Attributes are supported:

TRIGGER_SOURCE

EVENT_DESTINATION

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

RepCapIdentifier

If the property applies to a repeated capability, the user passes a physical or virtual repeated capability identifier. Otherwise, the user passes VI_NULL (0) or an empty string. For properties requiring nested repeated capabilities, enter the names separated by a colon as in: "Window1:Trace2".

cu32

Selects which attribute will be accessed. Following attributes are supported:

TRIGGER_SOURCE : Sets the string containing hardware trigger input pulse ("Immediate" or "EXT" or "PXI<n>"). While setting, "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5". If the specified source value is other than "Immediate", the driver automatically sets the Event Destination to "OFF" before setting the source value.

EVENT_DESTINATION : This is a string containing hardware trigger output pulse ("OFF" or "EXT" or "PXI<n>"). "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5". If the specified destination value is other than "OFF", the driver automatically sets the Trigger Source to "Immediate" before setting the destination value.

cstr

AttributeValue

The value to which to set the property.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:Event Configure.vi

Event Configure

This VI configures the trigger edge and width of the Destination (hardware trigger output pulse). When the input Trigger Source is Immediate, this method generate hardware or PXI bus trigger output pulse after set output level.

Remarks : Pulse width is in microseconds. Range is 0.02us to 300us, default value is 1us.

Agilent M9185.lvlib:Event Configure.vi

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

Destination

This is a string containing hardware trigger output pulse ("OFF" or "EXT" or "PXI<n>"). "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5".

ci32

Slope (Positive)

Trigger Slope is used to configure the trigger edge. It can either be Positive or Negative.

cdbl

PulseWidth (uS)

Pulse width (range 0.02us - 300us). Default value is 1us.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:Get Output Name.vi

Get Output Name

Returns the output name that corresponds to the one-based index that the user specifies.

Agilent M9185.lvlib:Get Output Name.vi

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

ci32

Index

A one-based index that defines which name to return.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.

istr

Name

The name of the 'Output' repeated capability at the specified Index value is returned in this parameter.


Agilent M9185.lvlib:Output Configure Function.vi

Output Configure Function

This VI configures the voltage/current function and output level for the specified channel. The specified level will not be placed onto the output until the specified Trigger occurs.

Remarks : This method does not enable output. To enable output, user can call the OutputEnable method before or after calling OutputConfigureFunction.

If user changes function on a channel, the output level is set to zero till trigger is received.

Agilent M9185.lvlib:Output Configure Function.vi

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

Output

A string that represents the channel. In most cases this will be 'Output1' through 'Output16' (the physical channel name). If a virtual channel name has been defined for the channel, that may be used instead.

ci32

Function (Voltage)

Measurement function (Voltage or Current) of the channel.

cdbl

Level

Output level of voltage/current.Voltage range is -16V to 16V with default value 0V and current range is -0.02A to 0.02A with default value 0A. Resolution for DC Voltage:16-bit = 500 uV and for DC Current: 16-bit = 630 nA.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:Output Group Configure Function.vi

Output Group Configure Function

This VI configures the voltage/current function and output level for the specified channel group.

NOTE : User must provide function array and level array of same size, and it must be at least as large as the number of channels being configured (channel 1 will be in array element 0).

Agilent M9185.lvlib:Output Group Configure Function.vi

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

ci32

ChannelGroup (All)

Channel group "All" to select "channels 1 to 16", "1to8" to select "Channels 1 to 8" and "9to16" to select "Channels 9 to 16".

c1di32

Function

Measurement function (Voltage or Current) for the channel group.

    ci32

            Function (Voltage)

    Measurement function (Voltage or Current) of the channel.

c1ddbl

Level

Array of double values for setting the output level of voltage/current.Voltage range is -16V to 16V with default value 0V and current range is -0.02A to 0.02A with default value 0A. Resolution for DC Voltage:16-bit = 500 uV and for DC Current: 16-bit = 630 nA.

NOTE : The specified Level must be appropriate for the specified Function at that same location in the array ( i.e. a level of 12 is OK for Voltage, but illegal for Current).

    cdbl

            Numeric

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:Output Group Enable.vi

Output Group Enable

This VI configures the relay state for the specified channel group.

Agilent M9185.lvlib:Output Group Enable.vi

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

ci32

ChannelGroup (All)

Channel group "All" to select "channels 1 to 16", "1to8" to select "Channels 1 to 8" and "9to16" to select "Channels 9 to 16".

c1dbool

Enable

Array of Boolean values to set the Relay state (True for "ON" and False for "OFF") for the channel group.

NOTE : Enable option for channel 1 will be in array element 0

    cbool

            Boolean

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:Set Event Pulse Width.vi

Set Event Pulse Width

This VI is used to set the Event Pulse Width.

Agilent M9185.lvlib:Set Event Pulse Width.vi

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cdbl

Event Pulse Width ( (uS))

Pulse width (range 0.02us - 300us). Default value is 1us.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:System Get Available Channel.vi

System Get Available Channel

This VI returns the availability of hardware output channel groups.

Agilent M9185.lvlib:System Get Available Channel.vi

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.

ibool

ChannelGroup1

True when Channel group (1 - 8) is available and False when it is Not Available.

ibool

ChannelGroup2

True when Channel group (9 - 16) is available and False when it is Not Available.


Agilent M9185.lvlib:Trigger Configure.vi

Trigger Configure

When the Event Destination is OFF, this VI waits for external hardware or PXI bus trigger input pulse before setting output level.

Agilent M9185.lvlib:Trigger Configure.vi

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

Source

This is a string containing hardware trigger input pulse ("Immediate" or "EXT" or "PXI<n>"). "PXI<n>" can be either one, or multiple lines, expressed as "PXI2 + PXI4 + PXI5".

ci32

Slope (Positive)

Trigger Slope is used to configure the trigger edge. It can either be Positive or Negative.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:Error Message.vi

Error Message

Translates the error return value from an IVI driver VI to a user-readable string.

Agilent M9185.lvlib:Error Message.vi

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ci32

Error Code

Instrument driver status code.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.

istr

Error Message

Instrument driver error message.


Agilent M9185.lvlib:Reset.vi

Reset

Places the M9185A into a known state. Following are the reset states of some parameters :

Functions set to "Volatge".

Levels set to 0.

All outputs are Eisabled.

Trigger source set to Immediate.

Event set to OFF.

Event pulse width set to 1 mS.

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:Revision Query.vi

Revision Query

Retrieves revision information from the instrument.

Agilent M9185.lvlib:Revision Query.vi

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

iivrn

instrument handle out

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

istr

instrument driver revision

Returns the revision of the IVI specific driver, which is the value held in the Specific Driver Revision property. Refer to the Specific Driver Revision property for more information.

istr

firmware revision

Returns the firmware revision of the instrument, which is the value held in the Instrument Firmware Revision property. Refer to the Instrument Firmware Revision property for more information.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:Close.vi

Close

Closes the I/O session to the instrument. Driver methods and properties that access the instrument are not accessible after Close is called.

civrn

instrument handle

The Instrument Handle that you obtain from the Initialize VI or Initialize With Options VI function. The handle identifies a particular instrument session.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:Initialize With Options.vi

Initialize With Options

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

Agilent M9185.lvlib:Initialize With Options.vi

cstr

resource string

A string that specifies the instrument to connect to. This can

either be a VISA resource name (also known as a VISA address)

or an IVI session, or an IVI logical name. For PXI instruments,

a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer

can be found using the Agilent Connection Expert.

To configure an IVI session or IVI Logical name, consult the IVI tools on your system, such as NI-MAX(Agilent devices may not appear in NI Max).

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

cstr

option string

The user can use the OptionsString parameter to specify the initial values of certain IVI inherent properties for the session. The format of an assignment in the OptionsString parameteris "Name=Value", where Name is one of: Simulate, RecordCoercions or DriverSetup. Value is either true or false except for DriverSetup. If the Options String parameter contains an assignment for the Driver Setup property, the Initialize function assumes that everything following "DriverSetup=" is part of the assignment.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.

iivrn

instrument handle out

Unique identifier for an IVI session.


Agilent M9185.lvlib:Initialize.vi

Initialize

Opens the I/O session to the instrument. Driver methods and properties that access the instrument are only accessible after Initialize is called. Initialize optionally performs a Reset and queries the instrument to validate the instrument model.

cstr

resource string

A string that specifies the instrument to connect to. This can

either be a VISA resource name (also known as a VISA address)

or an IVI session, or an IVI logical name. For PXI instruments,

a VISA resource name is of the form:

PXI[bus]::[device]::INSTR

PXI0::[bus]-[device]::INSTR

PXI0::CHASSIS[chassis]::SLOT[slot]::INSTR

For example, the following are syntactically correct strings:

PXI1::3::INSTR

PXI0:1-3::INSTR

PXI0::CHASSIS1::SLOT3::INSTR

VISA resource names for devices connected to your computer

can be found using the Agilent Connection Expert.

To configure an IVI session or IVI Logical name, consult the IVI tools on your system, such as NI-MAX(Agilent devices may not appear in NI Max).

cbool

id query (Off)

Specifies whether to verify the ID of the instrument.

cbool

reset device (Off)

Specifies whether to reset the instrument.

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

iivrn

instrument handle out

Unique identifier for an IVI session.

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.


Agilent M9185.lvlib:VI Tree.vi

VI Tree

The VI Tree displays all the user-callable VIs of the instrument driver in an organized table.

Agilent M9185.lvlib:VI Tree.vi


Related Documentation

To access documentation related to the M9185A PXI D/A Converter, use one of the following methods:

  • Browse the product CD
  • Browse the Manuals
  • Go to the product web site (www.agilent.com/find/M9185A) and browse the Manuals:
  • Start > Programs > Agilent > M9185: Provides links to all product documentation except for the IVI driver documentation
  • Start > Programs > Agilent IVI Drivers > AgM9185 DAC: Provides link to the product IVI driver help system
  • In context to your workflow. Click here for details.


Documentation Access


Agilent M9185.lvlib:IVI Error Converter.vi

IVI Error Converter

This VI converts error codes from IVI instrument drivers to standard LabVIEW error codes. If an error is detected the VI builds the appropriate error cluster that is readable by one of the error handlers supplied with LabVIEW.

Agilent M9185.lvlib:IVI Error Converter.vi

cerrcodeclst

error in (no error)

The error in cluster can accept error information wired from VIs previously called. Use this information to decide if any functionality should be bypassed in the event of errors from other VIs.

The pop-up option Explain Error (or Explain Warning) gives more information about the error displayed.

    cbool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ci32

            code

    The code input identifies the error or warning.

    cstr

            source

    The source string describes the origin of the error or warning.

ci32

IVI error code (0)

Error code returned from an IVI instrument driver operation.

cu32

instrument handle

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None

ierrcodeclst

error out

The error out cluster passes error or warning information out of a VI to be used by other VIs.

    ibool

            status

    The status boolean is either TRUE (X) for an error, or FALSE (checkmark) for no error or a warning.

    ii32

            code

    The code input identifies the error or warning.

    istr

            source

    The source string describes the origin of the error or warning.

iu32

instrument handle out

The instrument handle that you obtain from the Initialize or Initialize With Options VIs. The handle identifies a particular instrument session.

Default Value: None


Methods

This section provides detailed descriptions of the Agilent M9185A LabVIEW driver VIs.

See Also:
  • Programming examples
  • M9185A block diagram